Ansible role to get a modern acmetool for debian
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
L3D 575b83eb22
Merge pull request #2 from roles-ansible/v
4 days ago
.github Update metadata and release at galaxy 2 months ago
defaults Update acmetool version 4 days ago
meta increase version and required ansible is now 2.11 2 months ago
tasks Update metadata and release at galaxy 2 months ago
vars Update acmetool version 4 days ago
.yamllint Initial commit 5 months ago
LICENSE Initial commit 5 months ago
README.md increase version and required ansible is now 2.11 2 months ago

README.md

MIT License galaxy_acmetool

ansible role acmetool_fix

Ansible role to install a acmetool from the URL defined in defaults/main.yml.

This is needed on debian buster (debian10), because the acmetool release in the debian buster repos is to old.

We are using the debian sid (debian testing) repos.

This role is maintained until Debian Bullseye (debian11) is released and there is a more up to date version of acmetool.

This role is designed to work together with the do1jlr.acmetool role. But since it only install acmetool manually it will work on each debian based system, until debian bullseye is released.

Testing

This role is tested with these github-action tests for different versions of differen linux systems. Linting is tested via travis-ci and the ansible-lint action. If you want to find out more about our tests, please have a look at the github marketplace.

test status Github Marketplace
Ansible Lint check ansible-lint action
Yamllint GitHub Actions yamllint gitHub actions
Galaxy release publish-ansible-role-to-galaxy
Ansible check debian:stable ansible test with debian stable
Ansible check debian:latest ansible test with debian latest
Ansible check debian:sid ansible test with debian sid
Ansible check debian:buster ansible test with debian buster
Ansible check debian:stretch ansible test with debian stretch